OpenWebBeans

Monday October 01, 2018

Apache Meecrowave-1.2.4 has been released

The Apache OpenWebBeans team is proud to announce the release of Apache Meecrowave 1.2.4

Apache Meecrowave is a small java enterprise application server framework fully based on Apache Tomcat9 and other JavaEE 8 technologies.


    Apache Tomcat-9.0.12 (Servlets-4.0)
    Apache OpenWebBeans-2.0.7 (CDI-2.0)
    Apache Johnzon-1.1.10 (JSON-P-1.1 and JSON-B-1.0), and
    Apache CXF-3.2.6 (JAX-RS-2.1).

And all that in less than 10MB. That means it is ideally suited for Microservices and standalone applications.

Meecrowave can be either started via a maven plugin (for ease of development), programmatically as embedded server, bundled as application with your business code or as runner to start up portable WAR or JAR applications.


The source distribution package can be downloaded from our mirrors:
https://www.apache.org/dyn/closer.lua/openwebbeans/meecrowave/1.2.4

Hashes can be found here
https://www.apache.org/dist/openwebbeans/meecrowave/1.2.4

The binary artifacts are available on maven.central:
https://repo1.maven.org/maven2/org/apache/meecrowave/

Our main change for this bugfix release is adding preliminary Java11 support.
The full list of resolved tickets is:

Bug
    • [MEECROWAVE-130] - IOException if MEECROWAVE_OUT is different than MEECROWAVE_HOME
    • [MEECROWAVE-142] - error while starting jpda debug in a bundle
    • [MEECROWAVE-143] - [junit5] RequestScoped not activated with @MeecrowaveConfig
    • [MEECROWAVE-144] - update geronimo specs to new versions

Improvement
    • [MEECROWAVE-136] - update to apache-parent-21 for sha512
    • [MEECROWAVE-140] - Embrace JUnit 5 PER_CLASS support
    • [MEECROWAVE-141] - Add @AfterFirstInjection and @AfterLastTest for JUnit 5 integration

Task
    • [MEECROWAVE-133] - Upgrade to CXF 3.2.6
    • [MEECROWAVE-134] - Tomcat 9.0.12 upgrade
    • [MEECROWAVE-135] - Log4j2 2.11.1 upgrade
    • [MEECROWAVE-138] - update to Johnzon-1.1.9
    • [MEECROWAVE-139] - update OWB to 2.0.7
    • [MEECROWAVE-145] - update to Johnzon-1.1.10
    • [MEECROWAVE-146] - Upgrade commons-compress to 1.18
    • [MEECROWAVE-147] - Upgrade commons-dbcp2 to 2.5.0
    • [MEECROWAVE-148] - Upgrade commons-jcs to 2.2.1
    • [MEECROWAVE-149] - Upgrade acme4j to 2.3
    • [MEECROWAVE-150] - Remove commons-lang and commons-text from core dependencies

More info can be found at
https://openwebbeans.apache.org/meecrowave/ 

Calendar

Search

Hot Blogs (today's hits)

Tag Cloud

Categories

Feeds

Links

Navigation