Apache Maven

Tuesday August 23, 2022

Apache Maven PMD Plugin, version 3.18.0

The Maven team is pleased to announce the release of the Apache Maven PMD Plugin, version 3.18.0

A Maven plugin for the PMD toolkit, that produces a report on both code rule violations and detected copy and paste fragments, as well as being able to fail the build based on these metrics.

You can download the appropriate sources etc. from the download page.

You should specify the version in your project's plugin configuration:

1<plugin>
2  <groupId>org.apache.maven.plugins</groupId>
3  <artifactId>maven-pmd-plugin</artifactId>
4  <version>3.18.0</version>
5</plugin>

Release Notes - Apache Maven PMD Plugin - Version 3.18.0

  • New Feature:

  • Dependency upgrades:

    • MPMD-345 - Upgrade to PMD 6.47.0
    • MPMD-347 - Upgrade to PMD 6.48.0
    • MPMD-349 - Upgrade Maven Reporting API to 3.1.1/Maven Reporting Impl to 3.2.0
    • MPMD-350 - Upgrade Maven Shared Utils to 3.3.4
    • MPMD-351 - Upgrade Maven Artifact Transfer to 0.13.1
    • MPMD-352 - Upgrade Maven Common Artifact Filters to 3.3.1

Compatibility Notice:

  • For technical reasons the parameter sourceEncoding has been replaced with inputEncoding.

Enjoy,

-The Maven team

Comments:

Post a Comment:
Comments are closed for this entry.

Calendar

Search

Hot Blogs (today's hits)

Tag Cloud

Categories

Feeds

Links

Navigation