Apache Maven

Wednesday September 14, 2022

Apache Maven Shade Plugin, version 3.4.0

The Apache Maven team is pleased to announce the release of the Apache Maven Shade Plugin, version 3.4.0.

This plugin provides the capability to package the artifact in an uber-jar, including its dependencies and to shade - i.e. rename - the packages of some dependencies.

Notes:

  • Starting from this release you need JDK8 as minimum.
  • Minimum Maven Version 3.1.1.

You should specify the version in your project's plugin configuration:

1<plugin>
2  <groupId>org.apache.maven.plugins</groupId>
3  <artifactId>maven-shade-plugin</artifactId>
4  <version>3.4.0</version>
5</plugin>

You can download the appropriate sources etc. from the download page

Release Notes - Maven Shade Plugin - Version 3.4.0

  • Bug:

    • MSHADE-425 - Maven shade plugin build fails without 'clean' goal
  • Tasks:

  • Dependency upgrades:

Enjoy,

-The Apache Maven team

Calendar

Search

Hot Blogs (today's hits)

Tag Cloud

Categories

Feeds

Links

Navigation