Apache Logging Services

Sunday July 17, 2016

Moving on to Log4j 2: Log4j 1.2 is broken on Java 9

Log4j 1 has had a good run. First released in 1999, it is still widely used in a variety of Java-based projects. With Java 9, that is likely to come to an end: Log4j 1.2 is broken on Java 9. Essentially the MDC depends on the Java version string, which does not play well with Java 9's new version-string format.

To any project that is interested in running on Java 9, I'd strongly recommend migrating to Log4j 2 now.

[Read More]

Calendar

Search

Hot Blogs (today's hits)

Tag Cloud

Categories

Feeds

Links

Navigation