Apache Flex

Monday January 11, 2016

Apache Flex 4.15 Released!

The Apache Flex Community is pleased to announce the release of Apache
Flex 4.15.0

Apache Flex is a highly productive, open source application framework for
building and maintaining expressive applications that deploy consistently
on all major browsers, desktops and devices (including smartphones,
tablets and TVs).

Apache Flex 4.15.0 is a update to Apache Flex 4.14.1 that adds support for
the latest Flash Player and AIR runtimes, several bug fixes and TLF tables
and speed improvements.

Apache Flex is available in source form from the following download page:
http://flex.apache.org/download-source.html

It's recommended you install Apache Flex by using the Apache Flex IDE
installer:
http://flex.apache.org/installer.html

When downloading from a mirror site, please remember to verify the
downloads using signatures or MD5 hashes.

For more information on Apache Flex, visit the project home page:
http://flex.apache.org

Thank you for for your interest in Apache, and Apache Flex,
The Apache Flex Community

Comments:

Congratulations!

Posted by Jinqu Zhang on January 11, 2016 at 11:36 PM GMT #

very good~! thinks~!

Posted by bulesky813 on January 12, 2016 at 03:18 AM GMT #

Great work! Congratulations to Flex team. We are continuosly using Flex as main tool for out cross-platform projects. Thank you!

Posted by Bui Sy Nguyen on January 13, 2016 at 04:54 AM GMT #

I'm glad to finally see another, but It'd be swell to a list additions, changes, and fixes in the release.

Posted by David Hamiter on January 13, 2016 at 01:39 PM GMT #

David : We should have linked to the release notes in this blog post, as that document has an extensive list of all the changes and bugs that have been fixed. You can check it out here : http://ftp.wayne.edu/apache/flex/4.15.0/RELEASE_NOTES

Posted by Nick Kwiatkowski on January 13, 2016 at 03:04 PM GMT #

Is there someproblems with IOS simulator using xcode 7. I was waiting for update, hoping that would fix IOS Simulator error: Error occurred while packaging the application: unexpected failure: null java.lang.NullPointerException at com.adobe.air.ipa.IPAOutputStream.resignApp(IPAOutputStream.java:1006) at com.adobe.air.ipa.IPAPackager.renameOutput(IPAPackager.java:312) at com.adobe.air.ApplicationPackager.createPackage(ApplicationPackager.java:93) at com.adobe.air.ipa.IPAPackager.createPackage(IPAPackager.java:283) at com.adobe.air.ADT.parseArgsAndGo(ADT.java:604) at com.adobe.air.ADT.run(ADT.java:446) at com.adobe.air.ADT.main(ADT.java:496)

Posted by Mackey Kinard on January 14, 2016 at 11:29 AM GMT #

Fantastic - excellent work guys!

Posted by Stuart on January 14, 2016 at 10:18 PM GMT #

Congratulations - awesome to see these releases keep coming!

Posted by Evan Linwood on January 17, 2016 at 05:29 AM GMT #

Thanks Flex Team! Great Job!

Posted by Ferry To on January 25, 2016 at 03:46 AM GMT #

Very nice, thank you guys, the Flex / AIR combination rocks!

Posted by Paulus de B. on January 26, 2016 at 02:16 PM GMT #

Guys, we use Flex /AIR in combination with Granite Data Services, which provides for a real time user experience, very very powerful. These guys seem to have stopped development however but this could be a really valuable addition to the SDK and turn it into a real time cross-platform apps development platform. The code is at https://github.com/graniteds and the main developer is https://github.com/wdrai . Cheers and keep up the good work! Paulus.

Posted by Paulus de B. on January 26, 2016 at 02:26 PM GMT #

The published asdocs (http://flex.apache.org/asdoc/) are for 4.14.1. Is there a way to browse by release version?

Posted by Hari Khalsa on January 28, 2016 at 12:27 AM GMT #

Thank you very much for your team!I really appreciate your work!

Posted by wangtu on February 02, 2016 at 08:45 AM GMT #

I just tried release 4.15 and the iOS version of app does not work. The app works fine when using 4.14.1 with AIR SDK 20 to compile.

Posted by Andi: on February 04, 2016 at 02:04 AM GMT #

SDK Installer fails on validating download for Air SDK with error message; “Air SDK download failed”. I’ve tried uninstalling/reinstalling SDK Installer on my pc and clean install on my mac. Still can’t get it to work. Any help would be appreciated. Thanks.

Posted by Nick on February 10, 2016 at 04:07 PM GMT #

Good to see Flex still leading the way for developing a stable and consistent web application for an end user. Our team has been using Flex for more than 5 years and still didn't see an viable alternative in any other framework or language.

Posted by Rakesh on February 17, 2016 at 12:18 PM GMT #

Great job for a great development tool ! thank you for all your efforts and keeping it as the best.

Posted by H-Rabah on February 28, 2016 at 03:16 AM GMT #

Great job, congratulation!

Posted by Seth on March 08, 2016 at 02:09 AM GMT #

Post a Comment:
Comments are closed for this entry.

Calendar

Search

Hot Blogs (today's hits)

Tag Cloud

Categories

Feeds

Links

Navigation